记一次艰苦卓绝的Discuz x3 论坛升级过程

首先吐槽一下discuz 的官方论坛. 你要想下载到正确版本的discuz实在不容易找到. 有兴趣自己去看吧. 就是因为这个原因, 我本来想要安装x2.5版本(那时x3 还是Beta版本), 结果不小心下载成了x2.  也就是不久前, x3才发布正式版.   我最近想要安装几个插件,和皮肤, 但是打开插件中心, 发现我所有的插件都安装不了, 说我的版本不支持.

我确信是x2.5 的插件, 语言版本也没问题(我一直以为自己的论坛是x2.5), 这就奇怪了. 我也觉得discuz不会有这么明显的bug啊.网上搜了很多,都说是版本不对, 请仔细核对版本. 这问题一直困然了我很久.  当时没有紧急的需求,也就放下了.

直到今天, 我想安装插件和皮肤, 我决定把这个安装不了插件的问题搞定. 最终还是要核对版本, 我突然想到好像在别人的论坛下面看到过 类似 “x2.5” 的版权申明(就是在论坛首页的下面声明的).  再看看我自己的是 “x2”, 所以我猜测可能是我的版本安装错了.  所以本地搭建php环境(wamp server), 去discuz官方仔细找到2.5的下载地址. 本地安装.  证实我的猜测是对的. 我的论坛装错了.  现在查件中心绝大部分插件和皮肤都只支持2.5和3, 所以要想装查件, 只能升级了.

我的论坛已经有很多用户和数据了, 不能重装, 现在只能选择升级了. 好吧, 要升就直接升到最新x3吧.  好在官方的升级脚本还是比较详细的, 而且我也相信discuz的实力, 官方说支持从x2直接升到x3.

为了确保万无一失, 我先把服务器上的文件和数据库都备份到本地的php环境. 在本地”预升级”一次.  按照官方给的步骤,很简单就完成了.  打开页面看了一下,也没有发现问题. 放心了. 现在可以正式升级了.

第一步: 备份服务器的所有文件 和 数据库.

按照官方的说明把文件都拷贝上去: http://www.discuz.net/thread-3265731-1-1.html

因为我是用root身份登录到vps上去的,  所以拷贝上去的文件都是属于root的,  nginx 运行所使用的”www”用户是没有权限访问的. 所以要把权限都改对了,进入网站的根目录:

chown www -R *
chgrp www -R *

 

把网站的文件都改到 用户 “www” 用户的名下.

此时可以开始升级了. 运行: http://xxxxxxxx.com/install/update.php

问题出现了, 刚才预升级的时候, 这里就可以点下一步升级了. 但是此时提示 :

“请先升级 UCenter 到 1.6.0 以上版本。如果使用为Discuz! X自带UCenter,请先下载 UCenter 1.6.0, 在 utilities 目录下找到对应的升级程序,复制或上传到 Discuz! X 的 uc_server 目录下,运行该程序进行升级”

(当时没顾上截图)

什么? ucenter版本不对?  不可能啊, 我已经预升级一次了.  不会啊.   于是把服务器上的文件和数据库都恢复到升级前的状态, 进ucenter看, 发现版本号的确是1.6.  所以没问题.

然后又重复官方的教程.

最后运行: http://xxxxxxxx.com/install/update.php.   还是出现一样的提示.

反复按照官方的教程做了三次, 到这都是这个提示, 我确信我没有哪一步做错了. 这就奇怪了.

于是打开update.php文件, 找到这个提示的位置:

1

是这里在比版本号.

上面的code是我改过的, $oldversion 这个变量是我加的, 就是想把版本号显示出来, 看看到底是多少.

重新运行:  http://xxxxxxxx.com/install/update.php.

发现显示出来的版本号是空白. 什么也没有.

继续追踪: “uc_check_version” 函数, 因为版本号是从这的出来的.

搜索到uc_client/client.php

function uc_check_version() {
	$return = uc_api_post('version', 'check', array());
	$data = uc_unserialize($return);
	return is_array($data) ? $data : $return;
}

到了这里还是看不出来.

还是把服务器恢复原样, 和本地比看有什么却别.

恢复服务器文件和数据.

问题出在ucenter, 当然打开后台ucenter看看.

赫然发现: 通信失败

2

 

我很清楚的记得,  原来这里是绿色的通信成功的.

难道是因为和ucenter的通信失败了,  才导致update.php 文件获得ucenter的版本号失败, 所以导致我升级不成功的?

想到这里, 就要跟踪为啥通信会失败了.   (百度搜ucenter 通信失败, 很多人都说是论坛和ucenter之间的设置不一致导致的. 我也反复确认了很多次,设置没有问题.)

我们打开chrome的调试面板, 找到检查通信失败的地址:

点击左侧的 “应用管理”, 会发现下面这一条ajax的调用:

3

把这个地址在浏览器中打开:

4

 

发现他果然返回了通信失败的字样.

从上面的url 我们依次找到: uc_server/control/admin/app.php 文件, 并定位到 onping函数:

5

图中可以看到我注掉的调试代码, 都是我自己加的,为了跟踪代码的流程. 我发现流程是 进入了 “else” 块, 然后出来之后 $status就是空白.  下面在判断如果status是1表示成功. 否则就是失败.

我在本地成功的环境下, 重现类似的场景, 发现也是进入了else块, 但是出来的时候 status是1.

那就继续追踪 test_api() 这个函数.

搜索 “test_api”, 发现有两处定义, 分别在uc_client\model\misc.php  和 \uc_server\model\app.php.

第一处是空实现, 所以只能看第二处了.

	function test_api($url, $ip = '') {
		echo "in test pi".'<br>';
		$this->base->load('misc');
		if(!$ip) {
			$ip = $_ENV['misc']->get_host_by_url($url);
		}
                echo "line1:".$ip."<br>";
		if($ip < 0) {
			return FALSE;
		}
		echo "line2:".$ip."<br>";
		echo "line3:".$url."<br>";
		$ret = $_ENV['misc']->dfopen($url, 0, '', '', 1, $ip);
		echo "line4 ret value is:".$ret."<br>";
		return $ret;
	}

 

上面, 我加了一些调试代码.

发现 $ret是空白.

那就是dfopen的问题了.

搜索dfopen. 他有多处实现, 但是有两处比较可疑:

\uc_client\model\misc.php 和 \uc_server\model\misc.php

我现在两个实现的入口处都设置echo语句. 发现时走的第二处.

于是进一步跟踪第二处实现:

	function dfopen($url, $limit = 0, $post = '', $cookie = '', $bysocket = FALSE	, $ip = '', $timeout = 15, $block = TRUE, $encodetype  = 'URLENCODE') {
		echo "server model misc dfopen:"."<br>";
		//error_log("[uc_server]\r\nurl: $url\r\npost: $post\r\n\r\n", 3, 'c:/log/php_fopen.txt');
		$return = '';
		$matches = parse_url($url);
		$host = $matches['host'];

............

		if(function_exists('fsockopen')) {
			echo "server model misc dfopen:fsockopen"."<br>";
			$fp = @fsockopen(($ip ? $ip : $host), $port, $errno, $errstr, $timeout);
		} elseif (function_exists('pfsockopen')) {
			echo "server model misc dfopen:pfsockopen"."<br>";
			$fp = @pfsockopen(($ip ? $ip : $host), $port, $errno, $errstr, $timeout);
		} else {
			echo "server model misc dfopen:false"."<br>";
			$fp = false;
		}

................

 

我加了一些调试语句在里面.

当加到这里的时候,  想到,是不是 服务器的fsockopen函数被禁用了呢. 于是就没再继续加了. 赶快试. 上传文件, 刷新url.

果然输出了 “server model misc dfopen:false”

 

我擦, 原来是 fsockopen函数被禁用了啊.  赶快上传php的探针,  发现fsockopen果然被禁用了.

6

我这是才想起来,  前几天更换vps的时候, 没注意, 可能忘了打开fsockopen 函数了.

赶快去服务器:/usr/local/php/etc 中 打开php.ini  找到disable_functions这一行. 从中把fsockopen和pfsockopen都删掉.

然后重启php:  service php-fpm restart

然后刷新上面的url, 返回通信成功了.

好了,现在再回到开头.

把文件还原成升级前的样子, 再按照官方说明, 升级文件.

运行: http://xxxxxxxx.com/install/update.php

这次终于正常了, 显示准备完成,可以升级.

后面就比较顺利了. 自动升级数据库, 然后手动去吧缓存更新一下. 就好了.

就到这.

其中还省略了无数的弯路啊.

再次证明一个真理,  看似复杂的问题, 一定是由一个比较愚蠢的原因造成的.

 
byNeil
byNeil.com

原文来自 Blog by Neil, post 记一次艰苦卓绝的Discuz x3 论坛升级过程 转载请注明出处。本站保留一切权力

发表评论